Benutzer-Werkzeuge

Webseiten-Werkzeuge


kennwort

Kennworte

Paßwort-Container

KeePass / KeePassX

Unter Debian 9 ist die KeePassX-Version 2 Standard. Leider hat sich die Bedienung und Übersichtlichkeit verschlechtert, weswegen es sinnvoll ist die Version 1 weiter zu verwenden.

Unter Linux ist das die Version 0.4.4, die als Quelltext zur Verfügung steht:

wget https://www.keepassx.org/releases/0.4.4/keepassx-0.4.4.tar.gz

Abhängigkeiten

apt-get install xorg-dev libqt4-dev

Compilieren

QT4 muß Standard sein, ggf- qt4-default installieren

Bugs

In src/lib/random.cpp muß der Include <unistd.h> noch eingefügt werden, ansonsten bricht das Compilieren mit einem Fehler ab.

qmake PREFIX=/usr/local
make
make install
mv /usr/local/bin/keepassx /usr/local/bin/keepassx1

Quelltexte

kennwort.txt · Zuletzt geändert: 06.04.2018 14:35 von thooge