Benutzer-Werkzeuge

Webseiten-Werkzeuge


buster

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
buster [27.08.2019 08:57]
thooge [Debian Buster]
buster [12.04.2020 11:45] (aktuell)
thooge [Upgrade von Stretch]
Zeile 1: Zeile 1:
 ====== Debian Buster ====== ====== Debian Buster ======
  
-  * ecryptfs ist nicht mehr enthalten, vermutlich selbst compilieren+  * [[ecryptfs]] ist nicht mehr enthalten, vermutlich selbst compilieren 
 +  * [[redmine]] ist nicht mehr enthalten, ggf. Version 4.0.4 aus testing
   * leafpad ist nicht mehr enthalten, mousepad verwenden   * leafpad ist nicht mehr enthalten, mousepad verwenden
 +  * eclipse ist nicht mehr vorhanden
 +  * checkinstall ist nicht vorhanden, aus Backports verwenden
 +  * consolekit entfernen und durch elogind ersetzen
 +    * In /​etc/​pam.d/​lightdm-greeter libpam-systemd durch libpam-elogind ersetzen
  
 Neu installieren Neu installieren
   * elogind   * elogind
 +    * Backport mit der Version 241.3 machen, dann funktioniert auch Neustart und Herunterfahren<​code>​
 +mkdir elogind
 +cd elogind
 +apt-get source elogind
 +cd elogind-241.3
 +mk-build-deps --install --remove
 +dch --bpo
 +dpkg-buildpackage -us -uc
 +</​code>​
 +
 +Abhängigkeiten von systemd auf elogind umstellen
 +  * policykit-1
 +  * udisks2
 +
 +Policykit: Abhängigkeit korrigieren
 +<​code>​
 +mkdir policykit-1
 +cd policykit-1
 +apt-get download policykit-1
 +ar x policykit-1_0.105-25_amd64.deb
 +tar xf control.tar.xz ​
 +
 +Abhängigkeiten in control anpassen
 +  Depends: libpam-systemd | libpam-elogind
 +
 +tar c {post,​pre}{inst,​rm} md5sums control | xz -c > control.tar.xz
 +ar rcs policykit-1_0.105-25_amd64.deb debian-binary control.tar.xz data.tar.xz
 +</​code>​
  
 ===== Upgrade von Stretch ===== ===== Upgrade von Stretch =====
Zeile 13: Zeile 46:
 Prüfe ob Pakete verschwunden sind Prüfe ob Pakete verschwunden sind
   aptitude search '​~i(!~ODebian)'​   aptitude search '​~i(!~ODebian)'​
 +Bei Treffern, diese deinstallieren / aufräumen. Anschließend zur Kontrolle Befehl nochmals ausführen
  
 sources.list anpassen, stretch durch buster ersetzen sources.list anpassen, stretch durch buster ersetzen
   sed -i '​s/​stretch/​buster/​g'​ /​etc/​apt/​sources.list   sed -i '​s/​stretch/​buster/​g'​ /​etc/​apt/​sources.list
 +
 +''​sources.list.d''​ untersuchen ob dort noch Dateien liegen. Wenn ja auch auf Buster anpassen sofern möglich.
  
 Upgrade durchführen Upgrade durchführen
buster.1566889057.txt.gz · Zuletzt geändert: 27.08.2019 08:57 von thooge